조회 수 33 추천 수 0 댓글 1
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

최근에 올라온 daolcms 로 php 7.2.x + postgresql 10 버젼에 설치하면

마지막에 빈화면이 출력됩니다. ㅠㅠ

postgresql 권장버젼이 있을까요.

  • profile
    DAOL CMS 2018.10.23 22:46

    안녕하세요. :) 다올 CMS에 관심을 가져주셔서 감사합니다.

     

    먼저 최근에 올라온 다올 CMS 1.0.5.8 경우 PHP 5.6 이하 환경에서 완벽하게 지원되며,

    PHP 7.0 이상은 다올 CMS 1.1.0.0 부터 정상적으로 작동하도록 지원 작업을 진행 중에 있습니다. (12월 중 배포 예정)

     

    PostgreSQL 같은 경우 아직 테스트 서버 구축에 어려움이 있어서 확인 중에 있습니다.

    특히 Firebird, PostgreSQL, SQLite 경우, MySQL 등에서 추가된 기능이 DB Class에서 누락(함수 존재안함)되어 있습니다.

    그리고 XE 1.4.5.10 및 XE 1.5.4.3에서도 정상적인 사용은 불가능 한 것으로 보입니다.

    호환작업을 진행하여 지원을 유지할지 여부는 다올 CMS 1.1.0.0 배포 전 이와 관련된 사안이 결정될 것으로 보입니다.

     

    https://github.com/daolcms/daolcms/archive/develop.zip 베타도 아닌 테스트 버전이라 불안정할 가능성이 있으나,

    PHP 7.1 까지 지원되도록 수정되어 있어서 위 링크를 통한 설치역시 실패하신다면,

    PostgreSQL 사용은 어려움이 있을 것 같습니다.

     

    감사합니다.