조회 수 38 추천 수 0 댓글 1
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

mariadb-10.0.x/ PHP 7.0  환경 입니다.

  • profile
    DAOL CMS 2018.10.13 10:31

    안녕하세요. :)

    테스트 서버 기준, PHP 5.6 및 MariaDB 10.0.x에서는 다올 CMS 1.0.5.6이 정상작동 합니다.

    아쉽게도, 다올 CMS 1.1.0.0 미만은 PHP 7에서 어려움(작동은 가능하나, 일부기능 사용불가)이 있을 것으로 보입니다.

    일부기능 사용불가의 예로, PHP 7 부터 php_mysql를 지원하지 않아서 php_mysqli를 사용해야합니다.

    그러나, 다올 CMS 1.1.0.0 미만 버전은 mysql, mysql_innodb, mysqli만 지원하고 mysqli_innodb를 지원하지 않습니다.

     

    현재 PHP 7과 MySQL(MariaDB)의 호환성 개선 중인 다올 CMS 1.1.0.0을 준비중에 있으나, XE 1.11.0 버그(파일 업로더 버그 등)와 안정화 작업 및 기존 버전과 호환성 문제(템플릿 HTML 필터)로 지연되고 있습니다.

    cf. 다올 CMS 1.1.0.0은 마지막 PHP 5인 PHP 5.6 지원기간이 끝나기전에 완료하여 릴리즈할 계획에 있습니다.

     

    베타도 아닌 테스트 버전이라 불안정할 가능성이 있으나, 원하신다면 https://github.com/daolcms/daolcms/archive/develop.zip 를 통해 개발버전을 다운로드 받아서 사용할 수 있습니다.

    감사합니다.