조회 수 414 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

다올 1.0.2.0 부터 PHP 5.2에 대한 지원을 중단합니다.

다올에서 사용하는 코드가 PHP 5.2이하를 지원할 경우 PHP 7에 대한 지원을 할수 없어 지원 중단을 결정하였습니다.

어려운 결정이었지만, 공지를 올립니다.

 

다올 1.0.2.0 부터 PHP 5.3 이상에서만 지원됩니다.

 

변경 개요

* PHP 5.2 지원 중단. ( PHP5.2는 보안상 좋지 않으며, 대부분의 호스팅사가 PHP 5.3 이상을 제공하고 있습니다. )

* PHP 5.3 이상 지원

* PHP 5.3.10 이상 권장. ( 각종 보안 이슈로 인해 권장 버젼 이상을 사용하시면 좋습니다. )

 

추진 배경

* PHP 5.2에 대한 지원으로 인해 PHP 7 지원에 한계가 있음.

* PHP 5.3.10 버전의 함수가 다올 구조와 속도 개선에 효과적임.

* PHP 자체 보안 문제에 대한 방어에 취약함

 

핫패치 안내

기존에 배포된 다올 1.0.1.7 - 1.0.1.9 버전이 PHP 5,2에서 에러가 발생할 수 있습니다.

https://www.daolcms.org/download/3762 에서 핫패치를 적용하시길 바랍니다.

 

감사합니다.