조회 수 1193 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

다올 1.0.0.4부터 PHP 4.x에 대한 지원을 중단합니다.

테스트 환경의 어려움과, 현재, 대부분 서버 환경이 PHP 5 이상인 점을 고려하여 지원 중단을 결정하였습니다.

어려운 결정이었지만, 공지를 올립니다.

 

다올 1.0.0.4 부터 PHP 5.2 이상에서만 지원되며, PHP 4.x는 지원하지 않습니다.

 

변경 개요

* PHP 4.x 지원 중단. ( PHP4는 2008년 8월 7일에 End Of Life되어 보안상 좋지 않습니다. )

* PHP 5.2 이상 지원 ( 대부분 환경이 5.2 이상 입니다. )

* PHP 5.3.10 이상 권장. ( 각종 보안 이슈로 인해 권장 버젼 이상을 사용하시면 좋습니다. )

 

추진 배경

* 오래된 PHP 4.x에 대한 지원으로 인해 코드의 복잡도 증가 및 속도 개선에 한계가 있음.

* PHP 5.3.10 버전의 함수가 다올 구조와 속도 개선에 효과적임.

* PHP 자체 보안 문제에 대한 방어에 취약함

 

감사합니다.